Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account Compendium in Game, Join Today

[Script] Faerun Calender and Down Day Counter

1493919933
Nyn
Pro
This was exactly what I was looking for! Thanks so much for your hard work!
I am getting the same error as Craven on a blank campaign I just installed it on. However, on another campaign I had it installed on previously, it works great. This suggests there is an error in the initialization.
While I didn't get the error that Josh and Craven did when updating the script, I did notice that my date and ordinal days had been reset to the script default. Not sure if that might be part of what is causing issues?
1494004203
I load the Faerun 2.4 version and its working and since that is the world I am using I am all set but still get the error if I try the other one.
I'm currently using the script in a custom modern world setting, and it seems to be working fine. However, I'm not currently using any other scripts or even the OGL script.  One suggestion I'd make, and it's not a critical one, is to allow the GMs to customize the calender. I'm pretty sure this has been requested before. So don't feel compelled to do this any earlier than when you have the free time. No rush.  I also want to say that this is a very handy script and I'm very appreciative of you, Kirsty for taking the time to set this up. You rock.  Peace --Mike
1494014362
Kirsty
Pro
Sheet Author
Hey guys. Thank you for the bug reports. I'm going to try to get them fixed over the weekend. Mike, can you expand on what you mean by "customise" the calendar? The script is very much a work in (slow) progress so I'm interested in hearing what would be useful to everyone. 
1496460347

Edited 1496461570
I just tried installing v3.0.1 and get the following error after it spins up the new sandbox (I've disabled all other scripts but am using Shaped sheet v11.5.0 if that makes a difference); For reference, the error message generated was: TypeError: Cannot read property 'now' of undefined TypeError: Cannot read property 'now' of undefined at Object.checkInstall [as CheckInstall] (apiscript.js:1095:29) at apiscript.js:1117:11 at eval (eval at <anonymous> (/home/node/d20-api-server/api.js:146:1), <anonymous>:65:16) at Object.publish (eval at <anonymous> (/home/node/d20-api-server/api.js:146:1), <anonymous>:70:8) at checkForReady (/home/node/d20-api-server/api.js:1314:12) at /home/node/d20-api-server/api.js:1394:9 at c (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:14:64) at /home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:93:560 at hc (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:39:147) at Kd (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:93:546)
1496460468

Edited 1496468263
BTW, I was hoping to use the 'modern' calendar but change the names of the months, etc. That would be an awesome "customization" option. Edit: I found Modern 2.0 and installed and it works . Edit2: I was able to use Notepad to find and replace the months easily enough.
1496500002

Edited 1496501261
Doug E. said: I just tried installing v3.0.1 and get the following error after it spins up the new sandbox (I've disabled all other scripts but am using Shaped sheet v11.5.0 if that makes a difference); For reference, the error message generated was: TypeError: Cannot read property 'now' of undefined TypeError: Cannot read property 'now' of undefined at Object.checkInstall [as CheckInstall] (apiscript.js:1095:29) at apiscript.js:1117:11 at eval (eval at <anonymous> (/home/node/d20-api-server/api.js:146:1), <anonymous>:65:16) at Object.publish (eval at <anonymous> (/home/node/d20-api-server/api.js:146:1), <anonymous>:70:8) at checkForReady (/home/node/d20-api-server/api.js:1314:12) at /home/node/d20-api-server/api.js:1394:9 at c (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:14:64) at /home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:93:560 at hc (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:39:147) at Kd (/home/node/d20-api-server/node_modules/firebase/lib/firebase-node.js:93:546) Just as a note I am getting the same error when installing this script while using the shaped sheet version 14.2.3. Edit: I forgot to disable page navigator in my testing once disabled this script worked like a charm.
1496504054

Edited 1496504402
Kirsty
Pro
Sheet Author
Fixed the install problem.  Latest Version Edit: This should also resolve the problem of your days resetting upon installing a newer version of the calendar. Doug, I'm glad that you managed to edit the names of the months! Allowing for customization within the script itself is a little tricky because months don't always have the same number of days, leap years have to to taken into account and it would make the moon cycles even more difficult to implement. At this point, that's well beyond what I have time to work on. I'm not interested in adding anyone's homebrew to the "offical" version of the calendar, but I am willing to add other published settings for the community's use.
1496509696
It's a great script, thanks, editing the names was easy and now I'm playing with using it with The Aaron's Notelog script to date stamp log notes for my DM's log.
1496510366
Kirsty
Pro
Sheet Author
Oh, that's a really cool idea! I've been toying with a way to add events, but it's still very much a work in progress. 
1497988865

Edited 1497991538
Jedd
KS Backer
Marketplace Creator
I installed this script (Multi-World Calendar v3.0.2), and entered !cal to begin the setup, but nothing happened. Am I missing something? UPDATE: And it just started working. No idea why.
1498001103
Kirsty
Pro
Sheet Author
I'm glad you got it working, Jedd. If you have any other problems, please let me know.