We use Cookies to help personalize and improve Roll20. For more information on our use of non-essential Cookies, visit our Privacy Policy here.
Accept
Advertisement Create a free account

Shadowrun 5th Edition Version 4 (bug report)

There is a bug with the melee weapons's DV on the sheet tab. It shows the weapon's name and not the weapon's DV value. It's the same on the roll. Can you update it ? Thank.
1582609695

Edited 1582609825
That is really weird. I'll see if I can get a hot fix in for it. Edit: Just for note it works fine on the Arms tab. Just the primary weapon is unfortunately broke. - Cassie
Yes, this is weird ^^ Anyway thank you for this nice sheet !
1582650709
They use different attributes so it makes sense that the roll differently. I fixed this and found a bug with the skills which also was fixed. Thanks for posting. - Cassie. Fyi, I also released a Shadowrun 5th Edition api to compliment this sheet. Its in the one click drop down and directions of what it can do are in GitHub .
1582662829
Hey Cassie, The input for the attributes "physical" and "stun" seem to have flipped -- they now mean "wounds taken" rather than "boxes left". I understand why this is (after all, in SR you don't lose health, but take wounds) but it does mean I can't make health bars for my players. Is there a way to work around this? As always thanks for the continued work! :D
1582675834
Greetings Pippin, I did change this for the sake of my API which links health bars on tokens and also to reduce the number of extra attributes on the sheet. You'd set 'physical' for example linked to the token. Then you would put 0 in the first box and the total in the second box. Then the wounds add to the total rather than subtracting from the total. Its different but more intuitive since you are always 'taking damage' in Shadowrun rather than loosing health as you noted.
Thank you! Great news for the API script.
1582779692
You're welcome. I'm going to be expanding on it in the future. I want to make it easier to reroll dice with edge, calculate harden armor, penetrating barriers, and a few other task that I've setup a bunch of custom macros for which would be easier to share in an API. - Cassie
Would it be possible to add the switches on the character's matrix tab for the programs (for those you have loaded in your cyberdeck), like the one on the Host's sheet ?
im having issues with attack rolls its not adding there sill value to the roll only the attribute, this goes for both ranged and melee from the arms tab and core
Cassie, would it be possible to have all the skills (Hacking, fighting etc.) in the "attributes and abilities" tab. I use macros a lot and not having access to the skills is very disadvantageous. 
Update: There must be a bug : Skills are not updated when you change the number in the sheet, you must change it in the "attribut and abilities" tab. This is very strange.
None of the skills are showing up in the attributes and abilities tab for me
1584335371
Darshyne  Matirx,  You mean the 'power on' button? It use, I thought.... Attributes & Abilities ,  If you're looking for a list of skill names here is the code for all the hidden attributes . FracturedSolace  Thanks for the report. I'll see if I can get it fixed.
Thank you for the answer, is there a way to change those hidden attributes with API, like  "ChatSetAttr"? Or maybe do not hide them ? Yes i was thinking about the "power on" button, i would be nice to have it on the character sheet.
1584373434

Edited 1584374240
Darshyne Attributes:  You can change them with the API. What are you trying to do?  Power Button : It would be nice. I'll put that on my to do list. I've been refactoring a lot of the code because updating the old code safely is really difficult at the moment. FracturedSolace  The bug you reported should be fixed tomorrow. I refactored the code last night and it will go live tomorrow. FYI everyone, I spent all Saturday & part of Sunday night doing some heavy refactoring. Almost half the javascript was rewritten as well as some PUG/SCSS changes. This character sheet was one of the first big ones that I wrote. The code was pretty newb and it is now full of bugs due to hazardous work. So I've been writing it to be clean and to add unit test to help catch bugs before they make it live.  My apologies for any new bugs introduced but the upside is that I fixed about half a dozen this weekend. - Cassie
You'r doing a great job, this sheet is very nice and clean. the differents templates are great. I use a lot of Powercards to make combats more fluent, those powercards allow me to track a lot of things like : ammo, recoil, cover, range, speed modifiers etc.. I also use "ChatSetAttr" script to generate NPC and weapons quicker. Every combat and Matrix action in my campaign have a Powercard.  But for those things i need to get a lot of attributs data and sometime change them via API script like ChatSetAttr. So the problem is that i can't get those right from the Sheet, I have to duplicate them in a new attribut slot. 
the dice rolls for weapons and spells are still not adding the associated skills i am having to add the skill rating as a modifier on each weapon and spell manually. Could we also get a place to enter initiation level and meta magics  Other than that great sheet, its nice and easy to access and use. 
With the Api the roll initiative option, if I am using multiple tokens of the same sheet it rolls for each one but all the turns entered in the turn order are linked to just one of the tokens that it rolled for so i am having to enter each token but one manually. Am i using the macro wrong and am ment to make a character for each token instead of dropping the same one multiple times ?
1584451910
FracturedSolace  Weapons should be fixed later today. Spells may still be broken. I'll check on that this week. API, you shouldn't need to manually enter each one. It should just work by selecting multiple tokens then clicking the button. I'll take a look at this. I admit that I don't play this game any more. I often make things, do simple testing, and then send it live. I appreciate the help finding bugs from active users.
both weapons and spells are working with the exception of group skills (close combat group). Thanks for the fix
1584503287

Edited 1584504189
You're welcome. I have found a number of other things broken. I've spent the night fixing more stuff. Here is a partial list. Fix vehicles Refactor & fix Social tab Fix complex forums not total the right dice pool Change name of complex forms from spec to specialization for consistency Fixed issues with Sprites Fix weapons in the NPCs Add power button to the PC programs Add chat button to the PC programs Refactor more Javascript Fix Hosts / IC not calculating correctly FracturedSolace  Have you tried changing the skill being used to something else then changing it back?
Impressive work! Changing the skill in the cheet now change it in the attributs and abilities tab. Thank you! Would the reverse be possible?
I just find a bug: principal melee weapon can not be set. everything is fine with range weapon.
1584568274
Nooooooo!!!!! Probably a typo on my part that should be easy to fix. I'll take a look. Thanks, Cassie
1584570656

Edited 1584570703
sorry sorry .. I don't want to bother you but i think there is another issue with @{soak} computing, i have a soak value way too hight: 36 with an 10 armor and 2 body  (so x3 higher than normal).
Sorry probably sick of me at this point. No changing the skill on the weapon and in the skills from Combat group to something else and back didnt work, i also tried removing the skill and adding it again but that also didnt work. Adding a new weapon and tried linking it to Close combat group but still no luck. The melee weapons are not being added to the core page if primary is ticked, i tried adding new weapons and toggling it on and off but nothing is working so far, ranged is working fine thow.
Hello Cassie, here are the list of skills bugged/broken (3x higher than normal) : @{overflow} @{defense} @{soak} @{composure} @{judge_intention} @{memory} @{lift_carry} @{acid_modifier} @{cold_modifier} etc.
1584652561
@{overflow} @{defense} @{soak} @{composure} @{judge_intention} @{memory} @{lift_carry} are all controlled by the same function. It makes sense if one if broken they might all be. Probably a typo on my part. I'll get it fixed this weekend.
1584662813
Greetings, I put in a pull request for next week. It fixes all the common rolls being x3. I was accidentally adding them a second time. Fixed a typo causing melee primary script to break. Also fixed a translation key. Let me know after Tuesday if any additional problems persist. - Cassie
1584733621

Edited 1584741230
Thank you very much. Just a question, what is the purpose of @{primary_range_weapon_dicepool} attribut ?
1584744428

Edited 1584744803
Hey Cassie, Is there a fix for the skill names suddenly not appearing? Not sure if it's been mentioned already.
1584750544
Greetings Pippin, Try changing them in the select and changing them back. I change the attribute name to allow for translations for multilingual support. I wrote a script to convert it for everyone but it may have failed. :( I will look at that this weekend. Electronic Warfare may show "false". That's due to a translation key error which should be fixed next week in v4.13. If you see any other skills displaying as 'false' let me know. - Cassie
So far so good ! Thanks for the fix :)
1586647190

Edited 1586663607
any chance to get a drain_attribute 3 and 4 so mystic adepts can enter there drain code without changing there spell drain. You can change the sheet type to show sprites, grunts, vehicles can we get spirits added as well ? A way to change the defence value would also be nice so i can enter stuff like combat sense adept power.  never mind found it in settings
Not sure if were ment to put bugs with the api for the sheet here or not ? The option to roll initiative throw the api is not working, I have gone throw the trouble shooting it gives and everything is correct. I get the error with all character and npc sheets  
1587089429
Thanks for reporting it. I'll take a look. I broke it last week but it should have been fixed with this weeks' updates.
1587730738

Edited 1587730818
Hey Cassie, Just a quick bug report on the Grunt sheet again: 1) Armor rating doesn't show up as a number when filled in. Not that it matters much -- tend to use the soak button anyway. 2) Skills shows up twice! 3) Intrusion Countermeasures always shows up, whether it be grunt or vehicle. 4) Electrical Protection has a typo in it, the first C is missing. 5) Grunt condition monitors still work the reverse way -- they lose health, instead of take damage. As always, thank you for the work so far -- I especially really like having the option to click Drain on the roll output of a spell. :D
1587739865
Thanks for the bug reports Pippin. I'll look into those this weekend. I appreciate the feedback on the Drain roll.
The Api isnt responding anymore Failed to load Shadowrun 5th Edition No such file or directory @ rb_sysopen - /home/symbly/www/d20-app/apiscripts/Shadowrun 5th Edition/1.2/shadowrun5e.js Thats the error message from the api menu
1587849681
I think that's caused from a type. I'll fix it this weekend.
the Api works again thanks for the fix if i use it to roll initiative for multiple goons dropped down from the same sheet it rolls for each one but links all the rolls to only one of the tokens.
1588170245
Thanks for the feedback FracturedSolace. I'll have to take a look. Trying to roll init from a single sheet for multiple tokens is a bit tricky to get right. :)
Spells on grunts are a little off, it says the spell type were the force should be Can we get a drain attribute for grunts the linked drain on players is really helpful
1588443039
Fixed NPC Force issue in the Roll Template. I haven't added the button for drain. NPCs will need to have all that set somewhere on the sheet.
the Artificing skill is missing.
1589038518

Edited 1589038538
Added artificing skill to selects
1589910138
Cassie, I have a question. I'm just getting started using the sheet, and I'm getting stuck on trying to import a character. When I click on the Import button and paste in the JSON, it seems like nothing happens. Is there something I am doing wrong, something I should be aware of?  Thanks!!
1589922895
Elliot, It should be that easy. Can you email me your JSON file? I will PM you my emial. - Cassie
1589980088
Actually, the JSON file I was using must have been broken. I tried it with a different character, and it went off without a hitch. ID10T error. Thanks, though! :) 
1589983376
Is there a thread for general "how do I do X with this sheet" questions? I am very new to Roll20, still figuring out how to do various things.