Advertisement Create a free account

May 21 Infrastructure Update Bug Thread

1558457331

Edited 1559148139
Stephanie B.
Roll20 Team
We've upgraded a significant code library, which may cause unexpected issues. These may affect out-of-game pages, rather than the VTT, and are mainly related to raw HTML appearing in unusual places. Please report here if you find any issues in the forum, wiki, LFG, campaign forums, your profile, campaign settings page, or marketplace pages outside of the VTT . We will be hotfixing throughout the week as these minor issues show up. Known Issues (updated 5/29): The date picker previous/next buttons are missing (used for previous/next games). There is still a link you can click, but the buttons are invisible. The External Journal link returns a Page Not Found The personal notifications cannot be cleared from the Home page, but can be cleared elsewhere on the site.  (Fixed May 29) For some users, personal notifications cannot be clicked on. API scripts are returning an error for some users.   (Fixed May 28, Additional Hotfix May 29) Raw HTML or unescaped symbols appearing in: Source filters in the compendium  (Fixed May 24) Game description on the game details page  (Fixed May 24) Patch notes when patching a module/addon  (Fixed May 24) Notification emails from Roll20  (Fixed May 24) Add-Ons dropdown and list in the Game Details page LFG game listing description API descriptions The button at the bottom of the Add New Game page has turned into a standard hyperlink. Workaround: Use the button at the top of the page.  (Fixed May 24) When you visit the wiki, you are logged out of Roll20. Logging back in from the wiki will not persist.   (Fixed May 23) When the GM has shared their compendium in a game, the PHB content is not available to users who don't own the PHB. (This happens inside the VTT and is high priority to fix) (Fixed May 23) Some users are reporting an error trying to login ("NoMethodError"). The workaround is to use the login from another page, such as the forum. This is a high priority to fix.  (fixed May 22) The Pickup Games list is not updating All topics view in forum has unescaped characters Copying games with tags does not complete Web-based compendium does not load searchable sections such as spells, creatures, etc. Updates: May 23 Hotfix: Users are no longer logged out when going to the wiki. Please note that you may have been logged out this morning during the code push, but your login should persist now. Users who have access to the PHB through compendium sharing can now access PHB content. May 24 Hotfix: Fixed the following issues The End-of-page "I'm Ready, Create Game!" Button in creating/copying a new game was non-functional The Compendium Source had unescaped "&" symbols The game tags had unescaped characters and did not search on the full tag The Game Details page had unescaped HTML in Description The Patch notes for modules and addons displayed raw HTML The "Your Roll20 Notifications" emails contained raw HTML May 24 Hotfix: API Broke when using certain character sheets (such as D&D 3.5) May 29 Hotfix: API scripts failed for character sheets that were improperly UTF-8 encoded Personal notifications could not be dismissed from the home page, but were still working on other pages.
1558458250
I am unable to install API scripts from the library.  I go to the pull down bar, select Marching Order (as an example), but am not given the option to install, or even see the normal description of the script.
1558458698
Stephanie B.
Roll20 Team
Thanks, Barry. We can recreate the issue and the devs are working to fix it quickly.
1558458730
keithcurtis
Forum Champion
API Scripter
Confirmed. Me too.
1558459211
Not sure if it is related, but I am unable to create a game with the new "Ghosts of Saltmarsh" module.   It is listed as owned in the marketplace, but does not show up as a module that I have purchased when I go to create a new game.
Well, this is interesting: clicking Roll20 notifications now does nothing.
1558460065

Edited 1558460188
Stephanie B.
Roll20 Team
The API script installer has been fixed. BUT: The description of the script is showing raw HTML. 
1558460120
Stephanie B.
Roll20 Team
Which notification? The bell or the envelope, and did you have a pending (pink icon) notification already? Helen P. said: Well, this is interesting: clicking Roll20 notifications now does nothing.
1558460226

Edited 1558460274
That notification issue may be because I accessed Roll20 via a Discord link.  When I used a straight browser without involving Discord, it worked, so it may be unrelated to the update. P. S. Using a phone.
1558460306
Stephanie B.
Roll20 Team
OK, thanks! Helen P. said: That notification issue may be because I accessed Roll20 via a Discord link.  When I used a straight browser without involving Discord, it worked, so it may be unrelated to the update. P. S. Using a phone.
1558461127

Edited 1558461157
Pat S.
Forum Champion
Sheet Author
While using the all topics view I noticed some of  the forum titles are showing &amp: I would recommend making the reply post text window have larger default size. Right now it shows one line only until it is resized.
1558461288
Stephanie B.
Roll20 Team
Bill, Can you check to see if you can create a game with Ghosts of Saltmarsh now? This should be fixed. Bill W. said: Not sure if it is related, but I am unable to create a game with the new "Ghosts of Saltmarsh" module.   It is listed as owned in the marketplace, but does not show up as a module that I have purchased when I go to create a new game.
I can't access any External Journals from the dropdown menus on campaign pages.
1558462343

Edited 1558462359
Vince
Pro
Sheet Author
Chat logs might be affected by this morning's updates as well... <a href="https://app.roll20.net/forum/permalink/7469898/" rel="nofollow">https://app.roll20.net/forum/permalink/7469898/</a>
1558462558
Stephanie B.
Roll20 Team
Thanks for the report, Vince. That's an unrelated issue that's been happening for a long while. Vince said: Chat logs might be affected by this morning's updates as well... <a href="https://app.roll20.net/forum/permalink/7469898/" rel="nofollow">https://app.roll20.net/forum/permalink/7469898/</a>
1558462682
Vince
Pro
Sheet Author
Roger that.&nbsp; Thanks Stephanie B. said: Thanks for the report, Vince. That's an unrelated issue that's been happening for a long while.
1558462869
Drespar
Roll20 Team
From Elsewhere : Kooyt &nbsp;said: I tried to search for other issues about this but surprisingly no reports seem to have been made. When trying to access the&nbsp; Monsters List &nbsp;linked from the 5e compendiums page, the spinner on the page just keeps spinning forever and nothing loads. It seems that you are accidentally encoding some JSON through HTML-entities, since looking at the browser console, it looks like var listdata = {&amp;quot;name&amp;quot;:&amp;quot;3Monsters&amp;quot;,&amp;quot;category&amp;q... is the offending line on the page code. This happens on both latest Firefox and latest Chrome. Hope you fix it soon and I can get back to planning my campaign.
1558463379
Drespar
Roll20 Team
Hey Kooyt, This issue should be resolved now, can you confirm for me? :)
1558463780
Stephanie B.
Roll20 Team
Thanks for the report, Larris. I can recreate this and have logged a ticket. Larris M. said: I can't access any External Journals from the dropdown menus on campaign pages.
Unsure if related, but LFG appears to be broken. For me it is showing a pick-up game that started now almost 6 hours ago and no other games in the pick-up game section. I can also usually see games I'm in or running in the listing and in the pick-up games section, but a game I had intended to start in a little more than an hour that's looking for players and is ticked off as a pick-up game is not showing up whereas previous games I had listed in the same manner did show up there.
The View Message buttons on the notification icon (the envelope, not the alert bell) can't be clicked from the home page. If I move anywhere else into the site, it works and I can click through to the topics.
1558486605
Matt
Pro
We can all See the DM, but not each other after this update...
1558488204

Edited 1558488331
My players are reporting broken links when selecting PHB classes and some PHB races from within a newly created Saltmarsh game.
1558489631
Stephanie B.
Roll20 Team
Thanks for these reports-- I've made tickets for them and added them to the Known Issues. Sigilmancy said: Unsure if related, but LFG appears to be broken. For me it is showing a pick-up game that started now almost 6 hours ago and no other games in the pick-up game section. I can also usually see games I'm in or running in the listing and in the pick-up games section, but a game I had intended to start in a little more than an hour that's looking for players and is ticked off as a pick-up game is not showing up whereas previous games I had listed in the same manner did show up there. Loren the GM said: The View Message buttons on the notification icon (the envelope, not the alert bell) can't be clicked from the home page. If I move anywhere else into the site, it works and I can click through to the topics.
1558489886
Stephanie B.
Roll20 Team
Hi, Matt. Can you provide some more information? Is this happening inside the game? Chances are, this is a WebRTC issue, which is not related to this infrastructure update, but can be reported over in the WebRTC bug thread . Can you walk through the steps in the Solving Technical Issues &nbsp;to troubleshoot and rule out other issues? Matt said: We can all See the DM, but not each other after this update...
I don't know if this is related, but there is an issue with the chat log. When a button is pressed, nothing appears in the chat log, and all of the non-text content in the chat disappears.
1558491109
Stephanie B.
Roll20 Team
What do you mean when a button is pressed? Can you walk through the steps in the&nbsp; Solving Technical Issues &nbsp;to troubleshoot and rule out other issues? Most functions inside the VTT should not be impacted by this update.&nbsp; garrett t. said: I don't know if this is related, but there is an issue with the chat log. When a button is pressed, nothing appears in the chat log, and all of the non-text content in the chat disappears.
I tried the troubleshooting. It's not just on my end. My DM logged on and is having the same problem. As for what I mean when I say clicking a button. I mean the API scripts on the sheet do not show up in the chat. We've also tried typing text into chat and nothing shows up.
1558494096
keithcurtis
Forum Champion
API Scripter
The chat archive for the game is most likely corrupted.&nbsp;A game's Creator is often able to fix issues with their Text Chat by&nbsp; clearing the Chat Archive &nbsp;(note: not&nbsp; clearing your current Chat Log ). A GM might want to copy/back up the Chat Archive before the Creator clears it.
1558499500
Raw HTML also appears on tags and when I click on it, it does not search D&amp;D (or D&amp;amp;D in this case) but just D.&nbsp;
The last time I looked at this game's main forum page, it didn't have its formatting special characters as text like this: <a href="https://app.roll20.net/campaigns/details/4483571/one-shots-to-test-homebrew" rel="nofollow">https://app.roll20.net/campaigns/details/4483571/one-shots-to-test-homebrew</a> Next Game&nbsp; Wednesday May 22 9:30PM EDT (20 hours from now) &lt;p&gt;The next game will be at the time listed, but the plan is to schedule games at various dates and times so that anyone should be able to make at least some of the games if they want to. I will post the time for each game and you can show up if you are available on a given day. We can also discuss and schedule a time together for a one-on-one session or a session with a small group. If you know ahead of time that you will or will not be in a session, please let me know.&lt;/p&gt; &lt;p&gt;The next few games are listed in the forum below under Upcoming Start Times. Make sure to check your time zone.&lt;/p&gt; &lt;p&gt;If we have too many people on a given day, I will either assign a second DM, make that day&amp;#39;s game a fight club, or a combination of both. If you are open to DMing, let me know so I can assign you as a DM if needed. I&amp;#39;d love to test the classes with different DMing styles.&lt;/p&gt; &lt;p&gt;You can create a character (or I can create one for you) using my new class or a standard class, and fight monsters and NPCs alone or as a group. The goal is to play that character (or various characters) at multiple levels to see if they remain balanced as they increase in levels, but you can also just play the character once or twice. For more information in character creation, PM me or ask about it in game chat.&lt;/p&gt; &lt;p&gt;If you plan to stay for one game and leave, that&amp;#39;s fine, but make sure you leave the game so your space is open for others to join. When you leave, your character will be open for others to use unless you ask me to save it for you.&lt;/p&gt;
1558535165

Edited 1558535889
Stephanie B.
Roll20 Team
Helen, Never mind-- I can recreate that issue as a non-GM user and will get that looked at right away. Helen, I can't recreate this in Chrome on Windows. Can you hard-refresh the page for me (Shift-reload usually does the trick) and let me know if you're still seeing raw HTML?&nbsp; Here's what I see on that page: Helen P. said: The last time I looked at this game's main forum page, it didn't have its formatting special characters as text like this:
1558535189
Stephanie B.
Roll20 Team
Good catch! Thanks-- I'll make a ticket. 라브 said: Raw HTML also appears on tags and when I click on it, it does not search D&amp;D (or D&amp;amp;D in this case) but just D.&nbsp;
1558536429
Stephanie B.
Roll20 Team
I can recreate this issue. I don't know if that's related to this update, but we will tackle it as soon as possible. LeithalOne said: My players are reporting broken links when selecting PHB classes and some PHB races from within a newly created Saltmarsh game.
1558545429
Since the May 21st update the notifications envelope has been not working sometimes for me. I can see that I have 2 notifications and when I click on the envelope I get the drop down but when I click on the notifications nothing happens.
1558546024
Stephanie B.
Roll20 Team
Jim, This is in the Known Issues, that they won't clear from the Home page. Can you clear the notifications from anywhere else on the site? Jim C. said: Since the May 21st update the notifications envelope has been not working sometimes for me. I can see that I have 2 notifications and when I click on the envelope I get the drop down but when I click on the notifications nothing happens.
1558549887
Stephanie B.
Roll20 Team
Hi, all. We just fixed an issue that was preventing users from logging in and returning an error: " NoMethodError: undefined method `safe_concat' for nil:NilClass"
1558552426
Dragon Dreamer
Roll20 Mod Team
Moving report here:&nbsp; Ben S. &nbsp;said: I have noticed over the last couple of days as I've been receiving a couple of notifications - if trying to access them from the notification list - they are not redirecting when I click "view" but when I click the name of the sender or the subject within the notification, it leads to a page not found error.&nbsp; However, going to the LFG group or Private Message Inbox and viewing it there seems to work fine.
1558553417
Dragon Dreamer
Roll20 Mod Team
Moving report here:&nbsp; João V. &nbsp;said: Alguém poderia me ajudar? Não estou conseguindo acessar minha conta conta, toda vez que eu insiro meu login e senha e clico em "Entrar" ele me leva para uma página em branco com a seguinte mensagem&gt;&nbsp; NoMethodError; undefined method 'safe_concat' for&nbsp; nil:NilClass Não consigo acessar nenhuma outra conta depois disso, apenas quando eu limpo o histórico eu posso logar nas outras contas, mas essa em espicífico não entra de jeito nenhum. Por favor, poderiam me ajudar? -------------------------------------------------- Can anybody help me? I am not able to access my account, every time i enter my login an password and click on "Login" is takes me to a blank page with the following message&gt; &nbsp;NoMethodError: undefined method 'safe_concat' for&nbsp; nil:NilClass I can not access any other accounts after that, oly when i clear the history can i log in to the other accounts, but this one does not come at all. Please, coud you help me?&nbsp; (Sorry for the awful English)
1558559701
Hi, my post was moved to here - just to clarify that I cannot open the notification posts, not just not clear them.
1558564443

Edited 1558564957
Sorry, but. I'm trying to use the Shadowrun 5E sheets, and what I can access works, but you can't switch tabs on the character sheet.&nbsp; (I may be in the wrong forum, I apologize)
Being unable to create a game is a massive problem here, I can't get the standard hyperlink to work when you got to make a new game.
1558574975
Thanks for the reply Stephanie. The problem seems limited to the home page. When I am in the forums I can click on the envelope and the messages and all seems to work as normal.
Rare Kuma said: Sorry, but. I'm trying to use the Shadowrun 5E sheets, and what I can access works, but you can't switch tabs on the character sheet.&nbsp; (I may be in the wrong forum, I apologize) Me too
1558608234
I am running into two problems since the May 21st update. 1) API Scripts for one of my games stopped working and I get this error " Error downloading scripts (probably no scripts exist for campaign.) " I have tried restarting the sandbox but I get the same error. I have also uninstalled and reinstalled the scripts but with the same error, although it looks like it installs successfully first. I have also tried to copy the game and re-add the scripts to the new copy ... still no go. I have also tried rolling back the game to before the update and that didn't work either. Scripts I have installed. StatusFX, HTML Builder, Carry Tokens, Marching Order, MOTD, Elevation, TokenLock, Teleporter 2) A minor annoyance really ... When browsing from one page of roll20 to another it keeps signing me out. For instance when I go from the main page to the forums it'll ask me to sign in again. Any help would be appreciated.
1558608333

Edited 1558614096
I can't access the character vault because for some reason it doesn't show on mobile device's. Or to be specific the tools settings.
1558609936

Edited 1558614087
Aaron said: I am running into two problems since the May 21st update. 1) API Scripts for one of my games stopped working and I get this error " Error downloading scripts (probably no scripts exist for campaign.) " I have tried restarting the sandbox but I get the same error. I have also uninstalled and reinstalled the scripts but with the same error, although it looks like it installs successfully first. I have also tried to copy the game and re-add the scripts to the new copy ... still no go. I have also tried rolling back the game to before the update and that didn't work either. Scripts I have installed. StatusFX, HTML Builder, Carry Tokens, Marching Order, MOTD, Elevation, TokenLock, Teleporter 2) A minor annoyance really ... When browsing from one page of roll20 to another it keeps signing me out. For instance when I go from the main page to the forums it'll ask me to sign in again. Any help would be appreciated. I noticed the same issue before my game yesterday around 1PM EST. This happened in all my games after I restarted the API. This morning I followed the same troubleshooting steps that Aaron tried and I get nothing, even the load error will not be displayed. EDIT: Could these two issues be related? The login/authentication problem causing the API to not recognize PRO users and give access to API servers?
1558616732
Stephanie B.
Roll20 Team
Patrick,&nbsp; That's an old issue, but it is in our ticket system.&nbsp; Patrick G. said: I can't access the character vault because for some reason it doesn't show on mobile device's. Or to be specific the tools settings.
1558618788
+1 on Aaron and John F.'s problem: API Scripts for one of my games stopped working and I get this error " Error downloading scripts (probably no scripts exist for campaign.) " I've tried disabling and re-enabling scripts, restarting the sandbox... to no avail.