Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Dynamic Lighting - Updates, Bugs, & Feedback

1666794048
Thanks. I'll turn it off or abandon lighting altogether. I have issues with both explorable darkness and light crumbs. If I understand it right ED, is only revealed in rectangles (I would prefer a circular brush reveal) and, much light light crumbs, requires way more work from me as GM on the fly. I have enough going on in game as it is.
1666795944
Another question though. A while back, a feature was announced, feathered shadows, which would go a long way to achieving the effect im looking for. Despite an announcement saying this had been rolled out globally, August last year I think, I see no evidence of shadow feathering. Is this something that needs to be enabled, and if so how do you do it? For example; one of my maps with UDL and nothing else; This highlights something that I very much dislike about standard UDL. The thick black shadow lines or lines of sight. I think it makes for an ugly image, and appears totally unrealistic. I see no shadow feathering whatsoever in this image, except for where the torch light fades to dim light Now Explorer mode goes someway to improving this. By grey shading areas that are technically out of sight, it gives the illusion of softening the shadows and presenting a more naturalistic representation of the environment. However, for reasons, explained above, EM is essentially unusable. Same scene but with EM enabled... not perfect, the sight lines are still very hard edges, but they are muted somewhat by the greyscale. If the feathered shadows feature does actually exist, it would go some way to resolving my issue, without the need for EM (and associated problems).
1667562726
Hopefully someone can help. I'm running a game with 6 players and am using Dynamic Lightning. It's working as expect for all but one of the players. All tokens & character sheets have been setup the same (as far as I can see) but one of them can see through the layers. There is a really good example below, where I have clicked first on "Arctic's" token with cmd-l and you can see there are several rooms blacked out, but when I do the same with "Grimbrain's" token he can see through the blacked out ares and see that the map says "Secret Stairs"!!! Kind of ruins the mystery :( Any suggestions or ideas on how to resolve would be amazing! Screenshot 1: Screenshot 2:
1667747329

Edited 1667747724
Hi, bit basic, but have you tried allocating that token to yourself and logging out and back in as a player rather than using CTRL+L? Also, that player hasn't been given DM status by any stretch of the imagination?
1667748324
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
RowRow78 said: Hopefully someone can help. Ho RowRow78! Ctrl-L was never intended as a Dynamic Lighting proofer (despite considerable confusion over this in the past.) The L is for Line of Sight. And was originally intended just to verify that. If you want to test what players can see, the very best option is a  Dummy Account . You can keep it open in a separate browsing window, and get the true experience of what a player would see. The only exception is "Explorable Darkness", which IIRC, is user-specific, and independent of characters.
1667866938

Edited 1667868350
Mike
Plus
Hi, I've been running a game with 5 players and it happened more than ones that one or more players suddenly can see the whole map while using explorer mode and dynamic lighting. To my knowledge it's also not possible to reverse this issue. I also have no clue why this happens. The last time it happened it looked like someones roll20 app or website was bugging (to be honest also happens almost every week) so he reloaded the website and after that he was able to see the whole map. An other issue we have had various times is that a player wants to do a spell and he is unable to do that. At that moment he only keeps posting the spell description in chat. When I erase the spell and drop it in the character sheet again he is able to do the spell again.
1667868374
Gauss
Forum Champion
Mike said: Hi, I've been running a game with 5 players and it happened more than ones that one or more players suddenly can see the whole map while using advanced fog of war and dynamic lighting. To my knowledge it's also not possible to reverse this issue. I also have no clue why this happens. The last time it happened it looked like someones roll20 app or website was bugging (to be honest also happens almost every week) so he reloaded the website and after that he was able to see the whole map. An other issue we have had various times is that a player wants to do a spell and he is unable to do that. At that moment he only keeps posting the spell description in chat. When I erase the spell and drop it in the character sheet again he is able to do the spell again. Are you using Explorer Mode? I think most of the descriptions of people having issue with that are via Explorer Mode.  Additionally, the player really needs to file a bug report via the Help Center so the Devs can work with the player to track down the issue.  Regarding the spell, could you post a separate thread in the bug report forum so we can try to help troubleshoot it? Thanks
1667869978

Edited 1667870508
Mike
Plus
Hi Gauss. For some reason my reply doesn't show when I'm quoting, but yes it is in Explorer Mode. Was editing my post, but probably when you were already replying. I'll ask my players to file a bug report next time. Asked the one from today to file a bug report tomorrow. I'll make a separate post about the spell issue.
1667871917
Gauss
Forum Champion
Mike said: Hi Gauss. For some reason my reply doesn't show when I'm quoting, but yes it is in Explorer Mode. Was editing my post, but probably when you were already replying. I'll ask my players to file a bug report next time. Asked the one from today to file a bug report tomorrow. I'll make a separate post about the spell issue. Then the problem is most likely Explorer Mode (EM) with your player, I suggest disabling it.  You may need to reset that particular map's DL and/or have the player clear their cache etc. I am not sure where the EM information is stored. 
1667897363

Edited 1667898427
Hi Keith & Simon G. Thanks for the suggestions. I've signed in as him using his login details and he can see everything as shown in the screenshots. He hasn't been registered as a GM and it only happens when Explorer Mode is switched on - it only affects him however, none of the other players have the same issue. Support don't seem to be able to figure it out either :( They suggested using your Light Crumbs idea instead, but I'm struggling to get that to work as an alternative to Explorer Mode. (Unless you have any other suggestions)? keithcurtis said: RowRow78 said: Hopefully someone can help. Ho RowRow78! Ctrl-L was never intended as a Dynamic Lighting proofer (despite considerable confusion over this in the past.) The L is for Line of Sight. And was originally intended just to verify that. If you want to test what players can see, the very best option is a  Dummy Account . You can keep it open in a separate browsing window, and get the true experience of what a player would see. The only exception is "Explorable Darkness", which IIRC, is user-specific, and independent of characters.
1668026599

Edited 1668026737
Ross
Pro
I am having a recent problem where Dynamic Lighting is slow / lagging when I am the DM. If I use CTRL+L to observe what a single token sees, it is fine and I can move the token quickly, and the shadows render quickly. I know my computer is not a gaming machine, but this seems like a recent problem with the updated lighting (I had been using Legacy or not a all, because invariably it would never work properly for at least one player) . I wonder if the slowness is because in DM view, it is trying to calculate and draw the sight lines of all 10 tokens on the screen?  Is there a way to turn this off just for me?
1668036094
Gauss
Forum Champion
Ross said: I am having a recent problem where Dynamic Lighting is slow / lagging when I am the DM. If I use CTRL+L to observe what a single token sees, it is fine and I can move the token quickly, and the shadows render quickly. I know my computer is not a gaming machine, but this seems like a recent problem with the updated lighting (I had been using Legacy or not a all, because invariably it would never work properly for at least one player) . I wonder if the slowness is because in DM view, it is trying to calculate and draw the sight lines of all 10 tokens on the screen?  Is there a way to turn this off just for me? Some questions:  1) Which browser are you using?  2) What is the version number of your browser? 3) Is your Hardware Acceleration turned on? 4) Are you using Legacy Dynamic Lighting (LDL) or Updated Dynamic Lighting (UDL)? 5) Are you using Explorer Mode? 
1668442723
Ross
Pro
1) Which browser are you using?  Chrome 2) What is the version number of your browser? Version 107.0.5304.89 (Official Build) (64-bit) 3) Is your Hardware Acceleration turned on? Yes 4) Are you using Legacy Dynamic Lighting (LDL) or Updated Dynamic Lighting (UDL)? UDL 5) Are you using Explorer Mode?  Yes
1668444978

Edited 1668445067
Gauss
Forum Champion
Ross said: 1) Which browser are you using?  Chrome 2) What is the version number of your browser? Version 107.0.5304.89 (Official Build) (64-bit) 3) Is your Hardware Acceleration turned on? Yes 4) Are you using Legacy Dynamic Lighting (LDL) or Updated Dynamic Lighting (UDL)? UDL 5) Are you using Explorer Mode?  Yes So first thing I'd try is turning off Explorer Mode, see how that affects your performance. Explorer Mode is very resource intensive.  Some other thoughts: Have you tried Firefox? It may have a different experience.  Also, what is the size of the page (map)? Larger pages can experience more lag.  Do you have a lot of light sources or tokens on the map?  Are you granting yourself control over tokens on the map? If so, try not having control over every token as you are GM so you don't need it anyhow. It *might* reduce the calculations involved. 
1668448500
Ross
Pro
So first thing I'd try is turning off Explorer Mode, see how that affects your performance. Explorer Mode is very resource intensive.  That had no effect in either browser. Regardless, I would prefer not to have to disable features in order to get a lag-free experience.  Some other thoughts: Have you tried Firefox? It may have a different experience.  It had the same laggy performance in in Firefox Also, what is the size of the page (map)? Larger pages can experience more lag.  The map is 5mb so I thought that might be the problem - but I deleted it and refreshed the page, and it is still laggy.  Do you have a lot of light sources or tokens on the map?  No light sources Are you granting yourself control over tokens on the map? If so, try not having control over every token as you are GM so you don't need it anyhow. It *might* reduce the calculations involved.  I don't understand this question - I am the DM, I have control over every token. As far as I know, there is no way to NOT have control over every token. Controlling the tokens is the whole point....
1668449603
Gauss
Forum Champion
Sorry, I wasn't clear.  What size is the page (map). Number of grid squares (or hexes) by number of grid squares (or hexes).  Regarding control, some GMs assign themselves control over a token or character sheet the same as they do players. That is unnecessary since they have access to everything.  Now, I don't know if that adds more computations to things, but it might, so I was wondering if you do that.  Could you send me an invite so I can come take a look?
1668451202
Ross
Pro
It is only 24x20. The only thing I found that made a difference was disabling token vision for as many tokens as possible. I guess calculating the vision sightlines of 4 player tokens is just too resource intensive for my computer.
1668451705
Gauss
Forum Champion
Ross said: It is only 24x20. The only thing I found that made a difference was disabling token vision for as many tokens as possible. I guess calculating the vision sightlines of 4 player tokens is just too resource intensive for my computer. It shouldn't be, which is why I think something else must be going on. If I could come take a look I might be able to spot what is happening. 
1668453749
Ross
Pro
DM'd you an invite.
1668456721
David M.
Pro
API Scripter
Ross, don't suppose you are using freehand lines for the DL barriers? If so, this would create potentially thousands of line segments for the sight lines to check against which could impact performance. Best practice is to simplify use the polygon tool. 
1668457404
Ross
Pro
Nope, I am using line segments. As far as I know, I am following best practices and have everything properly configured.
1668460477
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Gauss said: Regarding control, some GMs assign themselves control over a token or character sheet the same as they do players. That is unnecessary since they have access to everything.  Assigning specific control, rather than relying on default control does have an effect on some DL situations, notably the transparency seen on some tokens in Explorer mode. IIRC, vision must also be turned on for such tokens, but it's been a while since I checked on that.
1668463745

Edited 1668463856
Ross
Pro
After logging in on some different computers, I suspect the problem here really is the computer itself. The lag was more pronounced on my older desktop with an Intel i7-7700. Trying it on my friend's computer doesn't have the lag when moving tokens, even with all tokens having Vision turned on.  I guess since I could play some older games  just fine on that older computer, that I thought it could handle dynamic lighting without problems. And to be clear, the lag doesn't make it unplayable, it is just annoying, because it feels like the framerate when moving a token drops to 1fps.
1668464518

Edited 1668465392
Gauss
Forum Champion
I took a look at your settings, it looks like you have Night Vision turned on for your NPCs, I definitely would not do that. Ctrl+L doesn't care about lighting and night vision, only line of sight. Second, I see that you turned on Dynamic Lighting for all of your NPCs...that is going to increase the workload on your system without explorer mode turned on. With explorer mode turned on my system was lagging a bit on your map too.  I would recommend dropping DL off of your NPCs, see how things work then.  Edit: I duplicated your page (the one with the player ribbon on it) and removed DL from the NPCs, it seemed to work better for me. But, I wasn't getting a huge amount of lag on my system so the difference could be subjective.  Give it a try, see how it works for you.  One other thing I noticed...just a bit of a tweak: I saw you drew a super long polygon/line. Most of your caves were one line, looping all around the cave path.  For a couple of reasons I can think of I don't recommend that.  1) Easier to make tweaks to shorter line segments.  2) I have seen occasional issues with very long windy polygon/lines.  Slightly related: I saw you close one of your polygon lines (head and tail meet), that is generally bad practice as it can introduce artifacts in the DL. Right click instead to finish a line, then draw another one. Have the lines intersect each other. 
1668467381
Ross
Pro
Thanks a bunch for checking things out. I'm gonna go down the list of recommendations and report back. You really are a forum champion!
1668468852
Gauss
Forum Champion
Some other things to investigate:  You mentioned an i7-7700, that shouldn't be a bottleneck for Roll20 if you have a decent videocard.  Are you running a lot in the background? I suggest when you are getting lag hit ctrl+alt+delete, open your task manager, see where your CPU and Memory resources are going. 
1668881258
Any suggestions how to set up vision when you have multiple tokens in control of a single player? There seems to be a bug where sights "add up" and the brightness of the view increases as there are more tokens with vision. This is somewhat problematic as I would like to have a shared view of 5 PC's on screen but it's almost like bright light when all of them occupy the same room.  I setup testing room which shows the difference: On the left there is three tokens with 60ft. Nocturnal Darkvision, on the right only one. There is no lights in the rooms and the effect is there even when stacking all of the token in the middle. The effect is even more noticeable when you add black tint to the vision:
1668935612

Edited 1668937662
Hiya, this is about how Roll20 implements darkvision, AFAIK there is no fix for it as yet. Players see this effect and DM's see it worse because, well, omniscient : )).  Tints are a great idea and with just one token having nocturnal on, you can really set mood with dark grey.  Unfortunately once multiple tokens have darkvision, this occurs and thus at this time my recommend would be to turn off any tint and just use transparent.  Nocturnal is still really good though, we love it at our table, but the day we can simulate that greyness will be one for a wee celebration (and that may include the coconut ones ; )    )
1668970715
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Trumble said: Any suggestions how to set up vision when you have multiple tokens in control of a single player? There seems to be a bug where sights "add up" and the brightness of the view increases as there are more tokens with vision. This is somewhat problematic as I would like to have a shared view of 5 PC's on screen but it's almost like bright light when all of them occupy the same room.  I setup testing room which shows the difference: On the left there is three tokens with 60ft. Nocturnal Darkvision, on the right only one. There is no lights in the rooms and the effect is there even when stacking all of the token in the middle. The effect is even more noticeable when you add black tint to the vision: Hi Trumble! Unfortunately not. The underlying mechanism of Dynamic Lighting uses this additive approach, and is one of the reasons modules are typically created with NPC sight turned off. Performance-wise, DL is actually pretty good with many sighted characters. But many characters with darkvision can create the illusion of bright light when controlled by the same player (such as the GM). There is a Mod script (Observer) which is typically used for streaming, which gives contorl over a token to an observer  Dummy Account  at the top of each turn, allowing the experience to shift based on whose turn it is. This is not really an actual play solution though. Is there a reason for the multiple player control? perhaps that could be addressed. Last note, I would advise against using the tinted vision feature. It is not well implemented and causes overlap problems with tinted light and other tinted vision, as you note.
1669369139

Edited 1669369216
I've discovered a bug  where no tokens emit any light,  and I've found a solution to said bug. (Recreateable 100% of the time) Perhaps this is already a known issue, but I'll post here what I've discovered. Bug : In maps with dynamic lighting, if you "Apply Token Defaults" to a token with Night Vision  enabled  (dimming/nocturnal doesn't seem to matter), every entity on the map loses the "emits light" feature (it does not matter what layer they are in, even if it's in the "dynamic lighting" layer). Even adding in new tokens with "emits light" on or manually enabling/disabling emits light has no effect: nothing emits light after you press "Apply Token Defaults" to a token with Night Vision enabled. Current Fix : Open the token with night vision enabled and toggle off night vision. Save Settings for that token. Open the same token and toggle night vision back to on. Save Settings again. Voila! All the lights emitting entities come back on for no apparent reason. I can recreate this exact issue across multiple pages and resolve the issue in the same way every time. If this is known, great! If someone would like me to recreate the issue (and the fix) for them, I'm available.
1669401750

Edited 1669401895
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Mr. McDungeonMaster! I am unable to duplicate these results with these steps. But I do have some questions. By "Every entity on the map" do you mean regardless of which character they represent? I.e., if editing a goblin in this manner, do you lose sight on all goblins (possibly expected, for reasons below), or all monsters of every kind? If it is just all goblins, this behavior might be explainable due to order of operations. If you have modified one token, using  the individual token's token editing interface (as opposed to the  character's token editing interface-which edits the default token, instead of a specific placed token) then pressing "Apply Token Defaults" will set the default token settings, which may have darkvision turned off. If you are going to be using that button, make sure you edit the token through the  character's   token editing  interface,  instead of the token's  token editing interface. If you have edited the token through the  token's  token editing interface, pressing the "Use this token" button before the "Apply Token Defaults button should propagate all of those changes across all instances of the token, both placed and default. If none of this helps, or addresses your problem, or I am completely misunderstanding, please give more detailed step-by-step instructions, including what interface you are using to make or apply changes. I'll see if I can help figure out the issue, or file a report through a  Help Center Request  (which you can also do). This is an official feedback thread, but I'm not sure how rigorously monitored it is anymore.
1669541994
keithcurtis said: Is there a reason for the multiple player control? perhaps that could be addressed. We use it when not playing online to show everything on one large screen. 
1669585447
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Ah, then unfortunately, this is not something that DL was designed for. Night vision is additive. If you have multiple overlappers, each wants to turn dim light to bright light, even if the dim "light" comes from another player's darkvision. There are some options at the Pro level. For example, the Observer script can give a  Dummy Account  vision control of whatever token is currently at the top of the turn order, giving the effect of showing what the active character sees. At the Plus level, you could also use  Light Crumbs  to sprinkle universal observers manually.
1669815956
BUG For some time now, when I have the diynamic light layer selected and I want to draw something with the polygon tool, the colour menu appears behind the tools. Is it only me?
1669827640
It's not only you and yes, this is extremely annoying. The color picker should at least be shifted to the right far enough to avoid overlapping the controls. (Left justified with the wall type/color/line weight window) I also still don't understand why the color picker for the DL layer has to be different from the one used on the other layers.
1669832370

Edited 1669832782
My animated tokens stopped working as of this morning. We played a game last night, tokens worked fine, players were very impressed, etc. This morning, saw that we had windows as an option. Went to the same map I was on last night, didn't notice anything out of the ordinary. I'm not 100% that my icons were animating at this point, because I wasn't really paying attention, unfortunately. Followed the "take a tour" of the window feature instructions, dropped a window down. Realized after I did this and played around with the window, that my animated icons no longer animate. Additional weirdness: If I move the token, ping the map, or if I scroll the window, I can make the token update its animation frame by frame. When I stop, the animation update stops as well. I had put down animated icons in two different maps, and only placed a window in one of those, but both maps no longer have functioning animated icons. Things I tried that didn't fix it: removing the existing icon and placing a new instance of the same icon opening a new map, placing an animated token from a different token pack refreshing the tab closing the tab and opening it back up opening roll20 in chrome (where we had last night's game and where I placed the window originally) and also firefox (where I had to do a fresh login) The two token packs I tried are these ones: <a href="https://marketplace.roll20.net/browse/set/3798/weather-overlays" rel="nofollow">https://marketplace.roll20.net/browse/set/3798/weather-overlays</a> <a href="https://marketplace.roll20.net/browse/set/3799/animated-spell-fx-vol-1" rel="nofollow">https://marketplace.roll20.net/browse/set/3799/animated-spell-fx-vol-1</a> There are a number of console errors related to being unable to run inline scripts due to Content Security Policy directives and a thumbnail that's hitting a 403. I can post a screenshot if needed. My tokens do not have a shader on them, nor vision turned on them. Edit: I have a video recording of the behavior, but realized I can't actually upload it here. Womp.
1669834821
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Sasha P. said: Edit: I have a video recording of the behavior, but realized I can't actually upload it here. Womp. You can upload it to a site like Imgur and post the link here.
1669835074
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
And yeah, I can confirm this behavior.
1669845275
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Looks like it has been fixed.
Ma tela de mapa esta todo preta hoje e isso começou ontem, não sei o que fazer para solucionar isso.
Eduardo SS &nbsp; My screen is all black, it all started last night and I still don't know how to solve it, it started after the implementation made yesterday. Awaiting.
1669909845

Edited 1669912525
I have been working on trying to make a magical darkness effect for my Pathfinder 2E campaigns. My experiments with the Permanent Darkness tool have been disappointing. Here is what I have learned... Permanent Darkness shapes do not block light from light sources OUTSIDE the permanent darkness shape Permanent Darkness shapes do not suppress light sources INSIDE the permanent darkness shape Permanent Darkness shapes do not block the line of sight for Night Vision or Bright Light vision tokens OUTSIDE the permanent darkness shape Permanent Darkness shapes do not block vision for Night Vision or Bright Light vision tokens INSIDE the permanent darkness shape What am I missing here? This appears to be a black shape that I can draw to cover up the map.... just like the drawing tool, but players cannot move, edit, or delete the drawing... Is this tool even part of the UDL system? It does not appear to have any lighting impacts whatsoever.
1669909957
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hórus M. said: Eduardo SS &nbsp;My screen is all black, it all started last night and I still don't know how to solve it, it started after the implementation made yesterday. Awaiting. Hi&nbsp;Hórus! A number of users have reported this, it doesn't seem to be a Dynamic Lighting issue. I'd suggest capturing a&nbsp; Console Log ( Chrome , Firefox ) and filing a&nbsp; Help Center Request &nbsp;to create a ticket.
1670036908
Has anyone else had a problem with the new Windows feature being a hog on the system resources? Ever since Roll20 updated and added the Windows feature, my Roll20 has been an absolute hog on my system.&nbsp; I used to be able to run an external video chat system and Roll20 at the same time and very little impact on my frames-per-second for my video chat.&nbsp; Not now.&nbsp; My fps is 1 per second at best, and only when I have Roll20 open.&nbsp; If I minimize Roll20, no problems, but when it's open, no go.&nbsp; I'm hopeful Roll20 can find the source of that obvious issue and resolve it.
1670178628

Edited 1670178731
WindyJ said: Has anyone else had a problem with the new Windows feature being a hog on the system resources? Ever since Roll20 updated and added the Windows feature, my Roll20 has been an absolute hog on my system.&nbsp; I used to be able to run an external video chat system and Roll20 at the same time and very little impact on my frames-per-second for my video chat.&nbsp; Not now.&nbsp; My fps is 1 per second at best, and only when I have Roll20 open.&nbsp; If I minimize Roll20, no problems, but when it's open, no go.&nbsp; I'm hopeful Roll20 can find the source of that obvious issue and resolve it. Yep, same issues for me. Seems to be on any browser I use, although Edge is slightly more usable. Not ideal, can barely have anything else running though. Not using Windows feature but roll20 in general seems to be using a lot more cpu and memory since the update.
Quick tip for those experiencing the 'infinite load on iPad due to dynamic lighting' issue: - Use Safari - In Safari settings, disable the 'WebGL via Metal' option This worked for us.
1671068840
Titus
Plus
Can confirm it worked for me too!…
Since the door update maps with dynamic lighting get stuck on load (Windows/Chrome)
1671564661
Really kind of disappointed to discover that using colored light still doesn't work right. Wanted to give a single, specific token colored light, the other tokens have no color set. When their default light intersects the colored light it still gets munged horribly (red becomes radioactive green). Works in Chrome, but looks like hot garbage in Firefox.
1672354724
Hello, I've been using dynamic lighting since its release and haven't run into this kind of issue. I was trying to modify a forest so it wouldn't be completely open. There's a ton of trees, so I put down a bunch of circles, copied them, and covered the forest, rotating them randomly as I went. Well as soon as I put a token down, I realized it didn't work. I can't think of a way to describe the issue with words, so I've linked several screenshots that hopefully make the issue clear. The circles largely worked as intended, but diagonal lines appear to come off them blocking line of sight. At first I thought it was just a circle glitch, or maybe something to do with my copying and pasting. So I put down a little plus sign as a test and found it had the same issue. That's what's shown in the screenshots. The circles are read by dynamic lighting as squares, at least at this size. That I understand and am fine with, however, each square seems to have a diagonal line coming off its bottom left corner and going up and left at a 45 degree slope. The + has the same issue, but the line comes off the top point of the plus.