Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Dark Mode VTT Bug Thread

1649146682
Something is indeed funky with darkmode.  I make a standard saving throw player template like say.....Fireball.  Spit it out with darkmode on, it looks totally fine.  Then if you toggle off and then back on Darkmode the color scheme becomes unreadable.  Same with inline rolls sometimes too but they need to be specifically done and then the toggle has to be done.  If you stay in darkmode 100% then no issue though.  
1649147102

Edited 1649147376
Just for Comparison: Just look at it and you can see what I mean... (I stay with light mode)
1649170028

Edited 1649170187
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
DM Eddie  said: keithcurtis  said: I just reloaded and refreshed the cache. I don't see any changes from what it has been for the last week. The tooltips look fine, but the npcatkdamage roll template is still wonky. Just to clarify for the guy trying to fix it, the template is &{template:npcfullatk} Thanks, I was typing in a hurry.
1649191718
keithcurtis said: DM Eddie  said: keithcurtis  said: I just reloaded and refreshed the cache. I don't see any changes from what it has been for the last week. The tooltips look fine, but the npcatkdamage roll template is still wonky. Just to clarify for the guy trying to fix it, the template is &{template:npcfullatk} Thanks, I was typing in a hurry. A totally plausible assumption about the templates name since the pc template is atkdmg.  But for some reason the npc sheets have a different naming scheme for autoroll damage.  
1649205459
Too many issues to round up, but my main gripe is handout wonkiness...In Dark Mode, the text is invisible unless one were to highlight it.   Without Dark Mode....BAM!  Looks perfect....Is this ever going to get fixed?
1649207722
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Shane! That is addressed upthread, along with the explanation of why this is unavoidable unless you take care not to transfer any external formatting. You are dealing with leftover inline CSS from wherever the text came from. Shift paste to get clean text and then format internally in order to avoid this.
1649207837
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Nice new fixes today . Particularly the one for thin lines: Fixed an issue where a player right next to a barrier could potentially cause peeking issues for light and vision through to the other side of the barrier. Fixed an issue where Players could potentially pass through Circles used as Dynamic Lighting barriers. Fixed an issue where Dynamic Lighting barriers didn't always block movement correctly after being rotated.
1649212540

Edited 1649213100
keithcurtis said: Hi Shane! That is addressed upthread, along with the explanation of why this is unavoidable unless you take care not to transfer any external formatting. You are dealing with leftover inline CSS from wherever the text came from. Shift paste to get clean text and then format internally in order to avoid this.  I figured it was something related to where I paste the text from.  I manage my campaign elsewhere and paste the entries from the campaign manager.  This is mostly because I enjoy the font I use from the campaign manager as opposed to the boring font offered by the VTT.  Hmm....I hate that this works great when not in Dark Mode.  Do you see any way around it?
Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings!
1649258212
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
TheMarkus1204 said: Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings! Which setting? The recovery rates for a variable number of sheet resources?
1649278672
keithcurtis said: TheMarkus1204 said: Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings! Which setting? The recovery rates for a variable number of sheet resources? I would have preferred the rest button system similar to multiclass hitdice, where its a toggle between showing and hiding it as I use resting in style and I don't trust my players with a button that massively messes up their sheet without an "are you sure about that?" message.  
keithcurtis said: TheMarkus1204 said: Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings! Which setting? The recovery rates for a variable number of sheet resources? Official Dungeons and Dragons 5E Sheet by Roll20. Dark mode enabled!
1649282062
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
TheMarkus1204 said: keithcurtis said: TheMarkus1204 said: Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings! Which setting? The recovery rates for a variable number of sheet resources? Official Dungeons and Dragons 5E Sheet by Roll20. Dark mode enabled! That identifies the sheet and the viewing mode. That's not what I was seeking clarification on, though. When you say "I really don't get why this setting is not a thing in the sheet settings", which setting are you talking about? You were talking about the cogwheel in the previous sentence. What setting do you want to be in the sheet setting?
1649328160

Edited 1649329334
keithcurtis said: TheMarkus1204 said: keithcurtis said: TheMarkus1204 said: Cogwheel for setting in class resources in dark mode hard to see! (grey, when hovering over them black!) I really don't get why this setting is not a thing in the sheet settings! Which setting? The recovery rates for a variable number of sheet resources? Official Dungeons and Dragons 5E Sheet by Roll20. Dark mode enabled! That identifies the sheet and the viewing mode. That's not what I was seeking clarification on, though. When you say "I really don't get why this setting is not a thing in the sheet settings", which setting are you talking about? You were talking about the cogwheel in the previous sentence. What setting do you want to be in the sheet setting? Why you are simply NOT able to apply this option (recover on short rest) globally to ALL Class resources. And as said in the respective thread, it'd be nice if you could select how many of your Hit Die you want to spent during a short rest. Regarding THIS thread the only thing that needs to be fixed is the black cog wheel while hovering over it...
1649347143
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
TheMarkus1204 said: Why you are simply NOT able to apply this option (recover on short rest) globally to ALL Class resources. And as said in the respective thread, it'd be nice if you could select how many of your Hit Die you want to spent during a short rest. Regarding THIS thread the only thing that needs to be fixed is the black cog wheel while hovering over it... Thanks, that's more clear. Some class resources recover on a short rest: ex. Warlock Spell Slots or Bardic Inspiration Dice for a 5th level bard. Others only on a long rest: ex. Barbarian Rage or Action Surge. There is no global rule, hence no global setting. Some resources are not class resources at all, and also have different recovery rates. The alternative, moving each resource setting recovery rate to the settings tab would result in needless duplication of space. The sheet has many examples of that gear icon being used to expand the settings on an entry: Equipment, Attacks, Traits, and more. Changing from the gear icon would be more confusing, not less. And I get your point about thread clarity, but since you raised the issue here, I responded here. If you want to work this out more or clarify where I may have misunderstood you, we should probably continue there .  Regarding the topic of this thread, I am sure your point about the cog wheel color has been noted. It is indeed an error that needs to be addressed.
Using official API Scripts and this gets displayed in chat when loading the campaign... Kinda hard to read in Dark Mode!
1649404491
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
There are no "official" Api scripts. Even the D&D 5th Edition by Roll20 script is community-created. And the API knows nothing of Darkmode. Has no control or knowledge of it, and can't use CSS variables.  Still the whisper notification "(From HealthColors):" looks oddly dark. Do all your whispers announce like that?
1649407836

Edited 1649408099
keithcurtis said: There are no "official" Api scripts. Even the D&D 5th Edition by Roll20 script is community-created. And the API knows nothing of Darkmode. Has no control or knowledge of it, and can't use CSS variables.  Still the whisper notification "(From HealthColors):" looks oddly dark. Do all your whispers announce like that? If I turn on Darkmode, yes, they do. This is what they look normally (light mode) EDIT: After switching BACK from light mode to dark mode, it looks like this: IF I connect directly in dark mode it looks like the screenshot I posted first about this. EITHER after switching modes OR reloading the page, they look "normal" (white font)
I have this Problem for EVERY campaign here on Roll20. If I enter a campaign it normally starts in dark mode (dark mode is enabled / used for the OS). All Text mostly looks like my first screenshot with Text / Playernames etc. barely readable. I need to EITHER reload the page (F5) OR switch to light mode and then back! It may be a .css Problem, because the class for dark mode is only added if you switch and taken away if you switch back. My assumption is, that it is applied wrongly and thus the color mixup happens not only for me but for everyone having those issues (yellow / orange for inline rolls with gray font color instead of purple background and white / black font)
1649863016
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
It has been a while since there have been any updates, and there are still parts of the interface that are unreadable . The most glaring is likely the npcfullatk template on the D&D 5th Edition by Roll20 Sheet, but there are others in the past few pages. This update had a strong start, and there are only a few things that need fixing. Any chance of getting an update on this?
Had an odd bug on my laptop where the Dark Mode even while toggled on was "Disabled" whenever scrolling with a scroll wheel on a mouse but scrolling up and down by using arrow keys is fine. And the problem only exists on my laptop. Not my desktop. Anyone else seen this or is it a rare fluke?
1649967051
Hello, i am unable to disable darkmode. Even when i toggle it off it still remains dark. How do i fix this?
David T. S. said: Hello, i am unable to disable darkmode. Even when i toggle it off it still remains dark. How do i fix this? Try to clear your browser cache and cookies. Then when in the campaign set it to light mode and reload the page (F5).
1650029790
Tom
Pro
Starfinder sheet is still broken if in Darkmode, if anyone cares still, I know I do :) Tom
1650222742
Issue with readability of rolls in chat. This is the Orbital Blues character sheet.
Just got this
Character sheet is still messed up
1650237326
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
PunyPaladin said: Just got this As far as I know, it's been that way for over two weeks. Did it just start for you?
1650237495
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
PunyPaladin said: Character sheet is still messed up Does it switch back to 3 column when you go to light mode? I've seen this reported before, and it's usually a browser setting or font problem, not a universal one. If' it is a font issue, it could be due to the differing font metrics between the fonts used for dark and light modes. Do you get these results on a different browser, or (if possible) a different computer?
keithcurtis said: PunyPaladin said: Just got this As far as I know, it's been that way for over two weeks. Did it just start for you? As far as I know, I've had this problem all along.
It happens in both FF (above) and Chrome (below)  
keithcurtis said: PunyPaladin said: Character sheet is still messed up Does it switch back to 3 column when you go to light mode? I've seen this reported before, and it's usually a browser setting or font problem, not a universal one. If' it is a font issue, it could be due to the differing font metrics between the fonts used for dark and light modes. Do you get these results on a different browser, or (if possible) a different computer? It looks normal in light mode.   If it's a browser setting, tell me which one and I'll change it.  
1650246799
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I honestly don't know. I've just seen some people report this over the years. I assume re-sizing the window and check the zoom level of the sheet and the browser do nothing? Looking closer, it appears you are using VTTES or similar. Try removing that and see if the display goes back to normal.
1650247026
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
PunyPaladin said: keithcurtis said: PunyPaladin said: Just got this As far as I know, it's been that way for over two weeks. Did it just start for you? As far as I know, I've had this problem all along. Me too. Well, actually it was working correctly for about a week and then broke with the last Dark Mode pass. I'd normally suggest posting this in the D&D 5th Edition by Roll20 Sheet feedback thread, but since the sheet is specifically called out in the top post, I would think it is being monitored. I have no idea why it has not been fixed. It's probably the most used roll template of the sheet. If you use Stylus, I do have a style solution that fixes it, but I won't be publishing it in-forum, because it only confuses Dark Mode reports. If this is keeping you from using Dark Mode, PM me and I'll send you the code.
1650258305
keithcurtis said: PunyPaladin said: keithcurtis said: PunyPaladin said: Just got this As far as I know, it's been that way for over two weeks. Did it just start for you? As far as I know, I've had this problem all along. Me too. Well, actually it was working correctly for about a week and then broke with the last Dark Mode pass. I'd normally suggest posting this in the D&D 5th Edition by Roll20 Sheet feedback thread, but since the sheet is specifically called out in the top post, I would think it is being monitored. I have no idea why it has not been fixed. It's probably the most used roll template of the sheet. If you use Stylus, I do have a style solution that fixes it, but I won't be publishing it in-forum, because it only confuses Dark Mode reports. If this is keeping you from using Dark Mode, PM me and I'll send you the code. I dunno, when I first started out dm'ing in roll20 I thought auto roll would save time but you kinda have to turn that off if you have any level of advanced reaction gameplay as you skip over a whole plethora of reaction possibilities like cutting words, smite, and other things.  I always just do query advantage and don't auto roll.  And if you do that, the template works just fine, its just when autoroll is on that dm's will see the npcfullatk template.  
Tom said: Starfinder sheet is still broken if in Darkmode, if anyone cares still, I know I do :) Tom Is it a community sheet or an official one by roll20? If it is a community sheet, you are out of luck here... If it is the official one by roll20 try posting your problems to the specific thread for the character sheet itself... this might be quicker as the devs don't look at this forum very often...
1650286396

Edited 1650286657
PunyPaladin said: Just got this Just reload the page and everything is fixed! I have the exact same problem, too, when entering a campaign in darkmode! If I join light mode and then switch, everything is fine... (and as said, I believe it to be a .css Problem with the class for darkmode is applied wrong or inconsistent! Why: Because RELOADING or switching to light and back to dark mode FIXES it)
1650291506
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Shoot. I can't make that work. No matter how many times I switch or reload, I get black on white on that one template.
1650295040
Tom
Pro
TheMarkus1204 said: Tom said: Starfinder sheet is still broken if in Darkmode, if anyone cares still, I know I do :) Tom Is it a community sheet or an official one by roll20? If it is a community sheet, you are out of luck here... If it is the official one by roll20 try posting your problems to the specific thread for the character sheet itself... this might be quicker as the devs don't look at this forum very often... Its the Official Roll20 one (so pretty unforgivable as one would think some or any quality control would have been gone through before general release, not just "well slapped it on the developement Server, no complaints, issues so time to launch ASAP!!) and EVERY player has this experience so should'nt take a rocket scientist to note before this was launched this was an issue for the Starfinder sheet. I'll try that  route as well,  thanks and tell all the players to do so as well, the barrage that might flood in just might tip them off, one would hope...... Tom
I've reloaded and that didn't fix it.   The page isn't zoomed. Disabling VTTES has no effect.   I don't use Stylus.  The problem persists in a private browsing window.   Resizing the window doesn't fix it either. 
1650307205
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Puny Paladin, I know I've seen the problem several times before. Looking back, it seems that the usual culprit is a malformed font, one with bad metrics. Here are some responses from threads or reddit posts where people have solved their instance: Now after much fiddling with Chrome I've managed to get a working character sheet AND ICONS. The extension is called "Fonts Changer" In Firefox the key point is not allowing the Roll20 site determine what's the font for things. That way I get a working character sheet but no icons. Now, if the Roll20Devs could look at those things that might help out more people with similar issues. response: The problem you're experiencing is caused by a missing or corrupted font file (possibly Arial). That can happen when a Windows update is applied, and go by completely unnoticed until you see the results like this.  The fix you've implemented bypasses the font selection, but please consider looking for support from Microsoft on how to repair or restore the font files for your particular version of Windows. and from Reddit I solved the problem by deleting my (seemingly corrupted) Helvetica font from my font folder in the registry. Hopefully that gives you a starting point.
Thanks, but I'm not using Chrome nor Windows
1650326263
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
PunyPaladin said: Thanks, but I'm not using Chrome nor Windows Those were just coincidentally the platform and browser of those people with the previous issues. Mac, PC or Linux can have a font issue. Do you have a different computer you can test on? (not trying to suggest you switch computers, OS, or browser, of course, just trying to help pinpoint the source of the issue).
Your suggestion is to delete fonts until it works?   That feels like a really bad idea.
1650393873
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
 I meant to examine the fonts the sheet uses. If you find one that is corrupted, then you should replace it (as you should with any corrupted font). Unfortunately, I only know font management on the Mac. I don't really know how to go about looking for a corrupted font on Windows or Linux. If you do happen to be on a Mac, You can inspect fonts on the sheet with the inspector as a clue for which ones to investigate with the Font Book app. At a quick glance, the sheet seems to use a lot of "Tiamat Text" in Dark Mode. I assume this is a web font, since it's not commonly installed. I do happen to have that font on my desktop computer due to being a contractor who works on WotC material. If I toggle the font off, the sheet does redraw very slightly (supporting that this is likely a web font) , but doesn't redraw to three columns or anything drastic. It's also possible that for some reason, your computer is not being served the right font at all. Sometimes AWS doesn't deliver all the way through. The fonts for regular text input seem to draw from the following definitions, in order of whether they are available: "Proxima Nova", "ProximaNova-Regular", -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;" That's as is served to my machine, which is identified as a Mac by the browser. It would be safest for you to right-click and choose "Inspect" on your side, if it's something you want to go to the trouble over. However... I'm just another user in this case. I'm willing to look into it further, but honestly I'm down to grasping at straws without actually sitting behind your keyboard. If you want more informed and official support, the best bet is a  Help Center Request . They will likely ask for a Console Log ( Chrome ,  Firefox ) from the time of opening a sheet. This sounds like a problem they have to deal with upon occasion. It's not terribly common, but I do see someone reporting it maybe a couple of times a year. If they do manage to work it out, please post back so the next time someone has this issue, they can hopefully find a solution as well.
If it's a corrupt system font, the problem should appear in Chrome too.   It doesn't.   If it's a corrupt web font, the problem should resolve by clearing the Firefox cache, or using a private browsing window.   Neither of those fix it either.  
1650411121
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Go with the console log to the Help Center, then. Obviously, something needed is not making its way to your screen.
1650422288
PunyPaladin said: If it's a corrupt system font, the problem should appear in Chrome too.   It doesn't.   If it's a corrupt web font, the problem should resolve by clearing the Firefox cache, or using a private browsing window.   Neither of those fix it either.   I had a missing font for a site other than roll20 and didn't get fixed till the site changed their font as many reported the issue.  I never saw any other issue except on their site.  
1650463741
Θ
Pro
Didn't see in the first post FAQ, is there a macro template for dark mode colors? I usually use the default template, which is hard to read now.
keithcurtis said: Go with the console log to the Help Center, then. Obviously, something needed is not making its way to your screen. I did, and Roll20 quickly responded.   It's a bug and they don't have a workaround and no ETA on a fix.