Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account
This post has been closed. You can still view previous posts, but you can't post any new replies.

[5e Shaped] Version 8+

1492028705
Vanakoji
KS Backer
Gary W. said: It isn't a big deal- was just making sure there wasn't an easy fix. On this particular one I ended up doing a click text to activate the command. The one &nbsp;that hurts is not being able to roll the tables on wild magic. It was so convenient to have the check and potential result rolled on every spell he cast.&nbsp; You can still get this easily just maybe not with the appearance you want. For example, two attachers setup (I just set both to roll wild magic) looks like&nbsp; <a href="http://i.imgur.com/JBRejmg.png" rel="nofollow">http://i.imgur.com/JBRejmg.png</a> The attachers are just&nbsp; <a href="http://i.imgur.com/RfrI9P7.png" rel="nofollow">http://i.imgur.com/RfrI9P7.png</a> The text is large because of the way the roll template handles [[ ]] text but it does work. You can also set the roll in each spells freeform field like (making the table roll on a new line)&nbsp; <a href="http://i.imgur.com/p4YHDrf.png" rel="nofollow">http://i.imgur.com/p4YHDrf.png</a> And with no attachers, look like&nbsp; <a href="http://i.imgur.com/A6VSFmr.png" rel="nofollow">http://i.imgur.com/A6VSFmr.png</a> and you can change the [[1t[Wild-Magic]]] to your table and include the !rt to get just the text. These are not the best solutions, but newline characters in anything outside a field's own freeform will always be iffy.
Thanks - let me play with that a bit. It is definitely a workable solution. Very grateful for the help.&nbsp;
1492180779

Edited 1492180873
is there a way to force update to 11.4? I have updated the companion script but the shaped sheet is remaining at 11.3. I'm hesitant to install a new sheet via custom code rather than the auto-update, as that's borkked my game in the past.
1492180816
Kryx
Pro
Sheet Author
API Scripter
The OP of the thread has instructions for how to manually update your sheet.
Right, but when will the auto-update go through (or is that not possible)? Again, last time I corrected this via making a custom sheet and copying the css and html my players lost dozens of fields in their sheets.
1492181012
Kryx
Pro
Sheet Author
API Scripter
Your players will never lose fields from updating. I haven't pushed to Roll20 for a week or two and probably won't for another week or two. There hasn't been much development - just minor things. If you're running the script you should always use the very latest of both the sheet and the script from github.
1492181951

Edited 1492182064
I guess I'm confused here from a user/development side of things. Between this and the companions script the sheet is no longer workable without considerable user-side updating and potential instability. Why wouldn't that merit pushing to Roll20? Anecdotally, I play in two games and run one using this sheet combo. One went backwards down to 11.3.3 on the companion script and things went fine. One is locked down and suffered data loss. I'm in the process of cloning my game and updating, but what im seeing the preview shows that the current html, css, and translation shown are not populating accurately when copying and pasting from github, which is concerning.
1492182343

Edited 1492182390
Kryx
Pro
Sheet Author
API Scripter
The script and the sheet expect you to always have compatible versions. Therefore the recommendation that we give when using both is to always have the latest. If you upgrade one and not the other problems can surely occur. Since you've upgraded one and not the other I'm suggesting you use compatible versions which requires you to get the latest. Pushing to Roll20 takes a week and can cause bugs that I am unable to solve for a week. Therefore I only update to Roll20 when I consider it stable. You will never receive any data loss. Never once has a user reported data loss. If you're experiencing what you think is data loss then please post a specific issue on my tracker with a simple reproduction path and a character imported to my test campaign I highly recommend you do not downgrade a sheet as there is no downgrade script to ensure that everything is the proper format for that version.
1492183647

Edited 1492183690
~eye-twitch~ I haven't updated anything yet. That's the problem . A week and a half ago, I run a game with no issues. Today I log on for preprep and everything is breaking. Lets make something clear here, for the non-tech savvy users using your sheet and companions script, pulling them from the stable Roll20 options, this is sheet is no longer usable without error messages lighting up literally everywhere: "5eShapedCompanion 1492183215223 INFO : Detected sheet version as : 11.3.3" "5eShapedCompanion 1492183215230 ERROR : Incompatible sheet version 11.3.3. This script only supports 10.x sheets. You either need to downgrade your character sheet or find a newer version of the script." So what I'm seeing here, and in this chat, is that the sheet pushed ahead of the shaped script causing this first stage of error messages, with the shaped script not updating to match. Then, when you come to the custom text, the opposite problem has occurred. On github the companion script is now ahead of the character sheet. Upon loading them manually in a copied game, i'm getting gibberish at the bottom of the sheet and nothing inside of "Character Traits" is working or updating. As a content creator, I get the idea of getting critique for content you are producing for free on the side as often annoying. I produce maps and content for free for roll20 players and I get that sort of thing too. But as someone whose content is essentially required for thousands of players, having greater coordination here with the live pushes seems like it would be a good idea. From what I've been reading around the internet, the current user solution is to delete the error messaging and ignore the updates at this stage. Which is functional, I guess, but also really kind of rediculous as a positive solution.
1492184088
Jamie
Plus
Encartrus said: ~eye-twitch~ I haven't updated anything yet. That's the problem . A week and a half ago, I run a game with no issues. Today I log on for preprep and everything is breaking. Lets make something clear here, for the non-tech savvy users using your sheet and companions script, pulling them from the stable Roll20 options, this is sheet is no longer usable without error messages lighting up literally everywhere: "5eShapedCompanion 1492183215223 INFO : Detected sheet version as : 11.3.3" "5eShapedCompanion 1492183215230 ERROR : Incompatible sheet version 11.3.3. This script only supports 10.x sheets. You either need to downgrade your character sheet or find a newer version of the script." So what I'm seeing here, and in this chat, is that the sheet pushed ahead of the shaped script causing this first stage of error messages, with the shaped script not updating to match. Then, when you come to the custom text, the opposite problem has occurred. On github the companion script is now ahead of the character sheet. Upon loading them manually in a copied game, i'm getting gibberish at the bottom of the sheet and nothing inside of "Character Traits" is working or updating. As a content creator, I get the idea of getting critique for content you are producing for free on the side as often annoying. I produce maps and content for free for roll20 players and I get that sort of thing too. But as someone whose content is essentially required for thousands of players, having greater coordination here with the live pushes seems like it would be a good idea. From what I've been reading around the internet, the current user solution is to delete the error messaging and ignore the updates at this stage. Which is functional, I guess, but also really kind of rediculous as a positive solution. That.. and statistically thinking.. not perfect.. but fits well enough... The A students.. maybe 10 percent of all your users.. follow and read this. &nbsp;The next.. the B students read most.. &nbsp;The rest of the 80 percent... most likely.. will not read any of this and will be really confused as to why stuff is breaking everywhere. &nbsp;I am an A student.. so I eventually figured some of this stuff out.. But most won't... And that is the problem I am around roll20 chats. &nbsp;;) &nbsp;Love the sheet! &nbsp;Just wish there was a better system!
Encartus- I have personally read posts where Kryx asked the developers for a different way to roll out the sheet. They said it couldn't be done. He is fully aware of the angst some of us get on these updates. Matter of fact both Lucian and Kryx have repeatedly stated the "safest" thing to do is take it off of updates to insure you have the proper companion script version matched with the proper character sheet version.&nbsp; Take their advice. If you want to lobby- lobby the developers- because it is out of Kryx's control.&nbsp;
1492184376

Edited 1492184486
Kryx
Pro
Sheet Author
API Scripter
Ah, you are using the one-click version of the script. I'm going to make this bold so it's very clear to everyone: Do not use the one-click version of the companion script. Lucian has said so multiple times in his forum thread. We've asked to have it removed, but Roll20 will not remove it. The message you're seeing from his script has been updated to be more informative in the latest version as the current message is very misleading. Install the latest version of the script and the latest version of the sheet. One click is (understandably) not supported by Lucian at this time. Encartrus said: Upon loading them manually in a copied game, i'm getting gibberish at the bottom of the sheet and nothing inside of "Character Traits" is working or updating. If you are on a supported version of the sheet (11.3.3 or 11.4.0) and using the latest script please file a bug as requested in the OP so I can address the issue you've encountered. As you've phrased it I have no idea what has occured. Encartrus said: As a content creator, I get the idea of getting critique for content you are producing for free on the side as often annoying. I produce maps and content for free for roll20 players and I get that sort of thing too. But as someone whose content is essentially required for thousands of players, having greater coordination here with the live pushes seems like it would be a good idea. We have a supported workflow and have that workflow for a number of reasons - the primary one being the limitating factor of Roll20's build system. I will not push a version of my sheet that is not tested, sorry. Encartrus said: From what I've been reading around the internet, the current user solution is to delete the error messaging and ignore the updates at this stage. Which is functional, I guess, but also really kind of rediculous as a positive solution. The erorr message is because you're not using the supported workflow. If you install the latest script (which works with Shaped 11.3.3 [current roll20 version] or Shaped 11.4.0 [current github version]) then this message will not show.
1492184599
Kryx
Pro
Sheet Author
API Scripter
Jamie (DM) said: That.. and statistically thinking.. not perfect.. but fits well enough... The A students.. maybe 10 percent of all your users.. follow and read this. &nbsp;The next.. the B students read most.. &nbsp;The rest of the 80 percent... most likely.. will not read any of this and will be really confused as to why stuff is breaking everywhere. &nbsp;I am an A student.. so I eventually figured some of this stuff out.. But most won't... And that is the problem I am around roll20 chats. &nbsp;;) &nbsp;Love the sheet! &nbsp;Just wish there was a better system! Most users don't have a Pro subscription and use the sheet without a script so this is a non-issue for them. Pro users are expected to install both versions from github to prevent any issues with versions. If there is a way to make this recommendation more clear please say so.
Is there a way to pull just the content of a repeating trait?&nbsp;
1492184946
Jamie
Plus
Kryx said: Jamie (DM) said: That.. and statistically thinking.. not perfect.. but fits well enough... The A students.. maybe 10 percent of all your users.. follow and read this. &nbsp;The next.. the B students read most.. &nbsp;The rest of the 80 percent... most likely.. will not read any of this and will be really confused as to why stuff is breaking everywhere. &nbsp;I am an A student.. so I eventually figured some of this stuff out.. But most won't... And that is the problem I am around roll20 chats. &nbsp;;) &nbsp;Love the sheet! &nbsp;Just wish there was a better system! Most users don't have a Pro subscription and use the sheet without a script so this is a non-issue for them. Pro users are expected to install both versions from github to prevent any issues with versions. If there is a way to make this recommendation more clear please say so. Hey... I love the sheet... I am just stating the reality of this... &nbsp;One, pro users or not... do not want to read anything... all the time.. to keep something working. &nbsp;They just don't. &nbsp; You have an expectation that is .... &nbsp; a hope. &nbsp;And I mean that very well. &nbsp; &nbsp;DO I want you to put out your sheet.. OF COURSE... Should you push it to roll20 at all &nbsp;.... NO.. That is where the problem is! &nbsp;Don't push it at all. &nbsp;Don't have it even on the one click thing. that and the companion script. &nbsp;That way.. people will HAVE to download what is given to you and is stable. &nbsp;That solved the big group of folks who don't read and don't care to read! &nbsp; :) &nbsp;This post is not to hinder but to help you understand the one click is the problem.. so remove it!
1492184998
Kryx
Pro
Sheet Author
API Scripter
Gary W. said: Is there a way to pull just the content of a repeating trait?&nbsp; @{NAME|repeating_classfeature_ID_content} @{NAME|repeating_trait_ID_content} Replace NAME and ID as recommended by the documentation.
1492185149
Kryx
Pro
Sheet Author
API Scripter
Jamie (DM) said: Hey... I love the sheet... I am just stating the reality of this... &nbsp;One, pro users or not... do not want to read anything... all the time.. to keep something working. &nbsp;They just don't. &nbsp; You have an expectation that is .... &nbsp; a hope. There is nothing to read. All Pro users have to do is just install the latest version of both the sheet and the script. It isn't complicated. Jamie (DM) said: This post is not to hinder but to help you understand the one click is the problem.. so remove it! I just wrote above why one-click is there. I know you don't like to read posts, but cmon... :P Roll20 won't remove it.
1492185273
Kryx
Pro
Sheet Author
API Scripter
11.5.0 UI Changes Conditions have been hidden from the sheet as their current setup has never really been fully supported. Hit points have been moved to after speed to better match the paper sheet. Temporary hit points and hit point maximum reduced have been moved inside the heart. Burrow, Climb, Fly, and Swim have been moved to the first line of the core page for better visibility. They only show in presentation mode when they have content. Bug Fixes Fixed a config for the script. See the first item at the script's 9.1.0 release
1492185448
Jamie
Plus
Kryx said: Jamie (DM) said: Hey... I love the sheet... I am just stating the reality of this... &nbsp;One, pro users or not... do not want to read anything... all the time.. to keep something working. &nbsp;They just don't. &nbsp; You have an expectation that is .... &nbsp; a hope. There is nothing to read. All Pro users have to do is just install the latest version of both the sheet and the script. It isn't complicated. Jamie (DM) said: This post is not to hinder but to help you understand the one click is the problem.. so remove it! I just wrote above why one-click is there. I know you don't like to read posts, but cmon... :P Roll20 won't remove it. See.. right there you took my last post as an attack and you went defensive.. I was just being nice saying that most don't want to read... SO, if you just stop pushing to one click.. everyone will have to get the working stable version from you and that is that... WOW man.. chill out and take the criticism in the good way I am putting it out there... &nbsp; And &nbsp;You could get a stable verson on the one click for everyone, since roll20 won't remove it .. and then just don't push any more forward. &nbsp;Those who want to upgrade..will HAVE TO go to your site and get it. &nbsp;easy peasy! &nbsp; AGAIN... &nbsp;I'm being Nice... &nbsp; so... please.. &nbsp;be nice too!
1492185799

Edited 1492185822
Kryx
Pro
Sheet Author
API Scripter
Jamie (DM) said: WOW man.. chill out and take the criticism in the good way I am putting it out there... What? I'm trying to make sense of your strangely structured messages, but perhaps there is some miscommunication. I made a joke that you don't like to read (using your words) as you asked a question that I had just answered. Jamie (DM) said: You could get a stable verson on the one click for everyone, since roll20 won't remove it .. and then just don't push any more forward. Those who want to upgrade..will HAVE TO go to your site and get it. easy peasy! Lucian hasn't pushed to roll20. That's exactly the state we are in right now. I'm not sure how much more clearly I can communicate this..
1492185862

Edited 1492185911
I didn't read Kryx as being particularly defensive here. The one-click option isn't going to be removed (and I see now that the problem lies there). A solution that works within this framework is to coordinate with shaped to set up a pair of editions to go out to one-click that work with each-other... and then never update them again and suggest players work as you have indicated in this thread. That way those who don't make it to the forums are still on a functional platform, albeit one that doesn't change, and those in the know can use more current/up to date and shiny versions of the sheets. If that's the plan once Lucian gets to it, no worries. On my end, I eventually found a solution via downgrading to the shaped companion sheet to 8.4.2.
1492185971
Jamie
Plus
No... you just do not want to listen to your users. &nbsp;And apparently... you just want to criticize now how I write my post or if I read or know how to read... WOW... for once .. I am not the problem here! &nbsp;You are the reason I may stop using your sheet.. not the roll20 issue! &nbsp;Back off!
1492186038
Kryx
Pro
Sheet Author
API Scripter
Encartrus said: A solution that works within this framework is to coordinate with shaped to set up a pair of editions to go out to one-click that work with each-other... and then never update them again and suggest players work as you have indicated in this thread. That way those who don't make it to the forums are still on a functional platform, albeit one that doesn't change, and those in the know can use more current/up to date and shiny versions of the sheets. If that's the plan once Lucian gets to it, no worries. This is not a workable solution as the sheet will continue to push its version to roll20 once its stable. It's only the script which will no longer do so. Even if Lucian updated one-click now the sheet would eventually put out a version that the script didn't like and we'd be in the same situation.
Is that so you can still support non-pro users with the core sheet?
1492186600
Kryx
Pro
Sheet Author
API Scripter
Encartrus said: Is that so you can still support non-pro users with the core sheet? This sheet is usable by all users - both Pro and non-Pro, yes.
Makes sense!
1492191737
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Would it be possible for Lucian to push an update to the script to Roll20 which only does one thing: Give instructions on the manual install and why this is necessary? That way, people would have to use the supported method. If they were absolutely dead set on using 1-Click, they could always choose the previous version, but the initial disclaimer would tell them why this is a Bad Idea. I just don't know if Roll20 would go for it. It seems they would, as a working sheet-script combo would be far better for the general play experience than lack of workable integration. If nothing else, the perhaps script could just have that disclaimer at the beginning of every time the API comes on line, so that people would continually get fair warning. I'll cross post this, assuming it's not a Bad Idea.
1492193359
Steve K.
Forum Champion
Sheet Author
API Scripter
Compendium Curator
Reminding everyone to remain civil. We can disagree without attacking each other. Kryx and Lucian are providing a valuable service to the community. Their Shaped Sheet offers different choices to users that I think are important. Their time and code are volunteer. The only person being paid to work on character sheets is me. So, if you're upset about character sheets you can PM me, it's my job. That said we've moved to a same time schedule for releasing character sheet updates and API One-Click updates so that the two remain in sync. This is the first I've heard about wanting the Shapes Companion removed from the library. If Kryx and/or Lucian could PM me with details we'll be happy to support the Shaped community to the best of our abilities.
Trying to make some formatting changes and need some help.&nbsp; Ideally I would like to make the Resources Tracking more compact by putting the spell slots into a 1/2/3/4 type of format. It would also be nice to be able to have th hero points and bardic inspiration dice on the same line. &nbsp; Here is what I am using at the moment. Any suggestions on what I need to change? &nbsp; {{Actions Available=@{repeating_trait_-KhXkjZ2oZpIKQRFqBLM_uses}}}{{Bonus Actions Available=@{repeating_trait_-KhXl-ok1WmNXtnHe8v0_uses}}}{{Reaction Available=@{repeating_trait_-KhXl795kpqUun0mSCpy_uses}}}{{Attack Actions Available=@{repeating_trait_-KhXlJC4v5dqV-f0ppFd_uses}}}{{Hero Points Available=@{repeating_trait_$0_uses}}}{{Bardic Inspiration Dice Available=@{repeating_classfeature_-KejYulwu48QLBvbi9Go_uses}}}{{Warlock Pact Slots Available=@{warlock_spell_slots}}}{{Spell Slots Available 1st Level=@{spell_slots_l1}}}{{2nd Level=@{spell_slots_l2}}}{{3rd Level=@{spell_slots_l3}}}{{4th Level=@{spell_slots_l4}}}
1492194019
Lucian
Pro
API Scripter
Well my position was totally invalidated by Steve's response, lol. Steve, I'll PM you and we can discuss further. I chatted to Phil about this previously and he was rather opposed to the Shaped Companion being removed from 1-click, which is where this comes from.
1492196831

Edited 1492196968
Kryx
Pro
Sheet Author
API Scripter
Gary W. said: Ideally I would like to make the Resources Tracking more compact If you're looking to create custom macros please reference the documentation and if you are unable to find the answer please make your own thread. Thanks.
1492243635

Edited 1492243783
Hello, is there a thread or a documentation for newbie on how to use the shaped sheet a bit like the one for OGL ? <a href="https://wiki.roll20.net/5th_Edition_OGL_by_Roll20" rel="nofollow">https://wiki.roll20.net/5th_Edition_OGL_by_Roll20</a>
1492243803
Jakob
Sheet Author
API Scripter
laurent d. said: Hello, is there a thread or a documentation for newbie on how to use the shaped sheet a bit like the one for OGL ? <a href="https://wiki.roll20.net/5th_Edition_OGL_by_Roll20" rel="nofollow">https://wiki.roll20.net/5th_Edition_OGL_by_Roll20</a> In the first post of this thread, you'll find a link to the sheet documentation.
Jakob said: laurent d. said: Hello, is there a thread or a documentation for newbie on how to use the shaped sheet a bit like the one for OGL ? <a href="https://wiki.roll20.net/5th_Edition_OGL_by_Roll20" rel="nofollow">https://wiki.roll20.net/5th_Edition_OGL_by_Roll20</a> In the first post of this thread, you'll find a link to the sheet documentation. Actually, the documentation in the first post is a little more for advance users rather than general users. laurent d. , do you have a general question on using the sheet? We definitely need an FAQ as was suggested in a previous post.
1492259520
Odd issue when upgraded to latest sheets and trying to update default settings [!shaped-apply-defaults].&nbsp; I have a PC using Articifer class, which failed with 4 lines of error messages.&nbsp; Thankfully I still have debug on from a while back, and was able to see the issue.&nbsp; The PC had both HP and hp.&nbsp; I deleted the hp [and ac for good measure].&nbsp; This resolved the issue,&nbsp; Not sure how we managed to get into this state, as I (am sure I) have never set this character to be an NPC. I doubt there is anything to be learnt here, but have saved the error message if it is of any use to anyone. I put this in char sheet forum thread because it was down to having extra data on the sheet itself.&nbsp; The issue would not previously have been detected because I have not run the command for this character before.&nbsp; For completeness I went back to a backup taken exactly 1 month ago - and the PC had the same extra fields.
1492260298
Lucian
Pro
API Scripter
Jim W. said: Odd issue when upgraded to latest sheets and trying to update default settings [!shaped-apply-defaults].&nbsp; I have a PC using Articifer class, which failed with 4 lines of error messages.&nbsp; Thankfully I still have debug on from a while back, and was able to see the issue.&nbsp; The PC had both HP and hp.&nbsp; I deleted the hp [and ac for good measure].&nbsp; This resolved the issue,&nbsp; Not sure how we managed to get into this state, as I (am sure I) have never set this character to be an NPC. I doubt there is anything to be learnt here, but have saved the error message if it is of any use to anyone. I put this in char sheet forum thread because it was down to having extra data on the sheet itself.&nbsp; The issue would not previously have been detected because I have not run the command for this character before.&nbsp; For completeness I went back to a backup taken exactly 1 month ago - and the PC had the same extra fields. Most likely this was due to a bug in the script which is now fixed. The sheetworkers and most of the application are case insensitive when it comes to attribute names, but the API, by default, is not. This can cause some strange issues when the API creates duplicate attributes. This shouldn't happen again because I've turned on case-insensitivity when searching for attributes, but there may still be old characters kicking around which have the problem, as you've found out! This is more likely to happen with OGL-converted characters, because the OGL uses different conventions for attribute names.
1492260796

Edited 1492260894
Lucian said: Most likely this was due to a bug in the script which is now fixed. The sheetworkers and most of the application are case insensitive when it comes to attribute names, but the API, by default, is not. This can cause some strange issues when the API creates duplicate attributes. This shouldn't happen again because I've turned on case-insensitivity when searching for attributes, but there may still be old characters kicking around which have the problem, as you've found out! This is more likely to happen with OGL-converted characters, because the OGL uses different conventions for attribute names. Ah so this is caused by the check for duplicates seeing HP and hp as the same? The error message includes Asked for a single attribute but more than 1 was found matching attributes Edit: I mean that before you turned on case-insensitivity this would have sailed through.&nbsp; I guess it's a case of the long term solution rocking a few boats in the short term. The original character was created as new for this game, as were all the PCs.&nbsp; NOne of the other PCs havethis issue.&nbsp; I think we had a problem and had to create a new sheet for this character - it was around the time Articifer was released as an option.
1492261229

Edited 1492261275
Kryx
Pro
Sheet Author
API Scripter
I don't know of anything on the sheet that would save "hp". It's always capitalized I believe. Issues like this without reproduction steps can't really be investigated.
1492275908
Lucian
Pro
API Scripter
@Jim: The duplication detection hasn't changed. This would already have been a problem before the recent change I made. The recent change should have prevented the script from creating new duplicates like this in the future. @Kryx: This was most likely created by the script, and most probably when configuring token bars. The script will have been looking for an attribute called hp (lowercase) - most probably because a token bar was configured to be 'hp' - and when it didn't find it, it would have created it. The sheet will obviously have been working with HP (upper) and then it's just luck of the draw which attribute the sheetworkers end up accessing. This can also be a problem with OGL that uses lower case. TL;DR: Don't worry about this, it's not a problem :-) If you do see an error like this, Jim's manual fix (delete the duplicated attributes) should work fine and it shouldn't recur.
1492280520

Edited 1492280562
Found an error in SRD content in companion script. Mummy entry has: "damageImmunities": "bludgeoning, piercing, and slashing from nonmagical attacks", Pretty sure it should be resistances. One Mummy almost killed us =(
Roman said: Found an error in SRD content in companion script. Mummy entry has: "damageImmunities": "bludgeoning, piercing, and slashing from nonmagical attacks", Pretty sure it should be resistances. One Mummy almost killed us =( Is that for a Mummy or a Mummy Lord? Mummy Lords have immunity; a Mummy has resistance.
1492283057

Edited 1492283098
Kryx
Pro
Sheet Author
API Scripter
Thanks for finding an error. I've updated the mummy and mummy lord (mummy lord had the incorrect vulnerability). Lucian will have to release a new script. We'll discuss if there is a better way for us to handle this updating process or if him grabbing the data ocassionally is fine with his new schedule.
1492358524
Kryx
Pro
Sheet Author
API Scripter
11.6.0 UI Changes Senses are now in the first row like speeds. Both speeds and senses have a toggle to show the "other" speeds/senses. The defaults shown are "Speed" and "Darkvision". Temp hp and hit point maximum reduced now default to 0. Hit point divider is now a straight line. Bug Fixes #450: Missing space between Spell Level and Spell School
Why is it that clicking and dragging in weapons from the Compendium no longer applies your modifier? &nbsp;Example: creating an empty data field in the Attacks box and dropping in Longsword from the Compendium doesn't automatically set its modifier to STR or STRENGTH. Plus holy cow this thread is big. &nbsp;Maybe we'll get a new thread for version 12.0
1492528198
Kryx
Pro
Sheet Author
API Scripter
Jebediah S. said: Why is it that clicking and dragging in weapons from the Compendium no longer applies your modifier? &nbsp;Example: creating an empty data field in the Attacks box and dropping in Longsword from the Compendium doesn't automatically set its modifier to STR or STRENGTH. Please see the OP for a link to my issue tracker where you can report this issue with reproduction steps. Thanks
Firstly, can I say what a fantastic sheet this is, alongside the script, the work and support is fantastic I know this is away from RAW etc, but I, and I think others, use a different calculation for Crit Damage, Max weapon damage + rolled weapon damage + Modifiers. &nbsp;eg 2d8(16) + 2d8rolled (9) +mod (4) = total 29 I understand if this is not possible, or way down the list, but I would like to put this out there.
1492537495
Kryx
Pro
Sheet Author
API Scripter
If you look on the settings page you can change "Critical damage" to "Critical damage is maximized" to achieve that behavior.
Ah sorry - thought that would just be 2d8(16) rather than 4d8 rolled - thats&nbsp;perfect, thank you